If you have problem with the OneSignal plugin on iOS (only of MAC), run: Then delete the directory “customlistingapp/platforms/ios/Custom Listing App/Plugins/onesignal-cordova-plugin” and run:

To resolve: Error: Cannot find module ‘sharp’Run this: Then: Check “ionic info” and look if your “Cordova-res” version is different from 0.6.0In case it isn’t 0.6.0 run:

IF you are having this error “[cordova] xcodebuild: Command failed with exit code 65” when running iOS app on simulator or trying to build iOS app it means a provisioning profile is not installed on Xcode: Follow this steps: Link Then remove node_modules folder and run:

If you have this error “Using “requireCordovaModule” to load non-cordova module “glob” is not supported. Instead, add this module to your dependencies and use regular “require” to load it” when running ng serve or when you try to build/run iOS or Android app you need to check if a wrong version of Cordova is installed. …

Using “requireCordovaModule” to load non-cordova module “glob” is not supported. Instead, add this module to your dependencies and use regular “require” to load itRead More »

A typical error you can have trying to running the code is: HTTP error 404 Not Found Downloading binary from https://github.com/sass/node-sass/releases/download/v4.11.0/darwin-x64-72_binding.nodeCannot download “https://github.com/sass/node-sass/releases/download/v4.11.0/darwin-x64-72_binding.node”:Hint: If github.com is not accessible in your location Try with this: Or if it doesn’t work, seems like you are using a too recent version of node.js, try to downgrade it with: